Jak korzystać z funkcji wyszukiwania w pionie w Excelu

Poradnik dodany przez: Excel-i-Adam
15417 0

W tym odcinku zajmę się jednym z pytań od widzów a film będzie dotyczył funkcji wyszukiwania w pionie, czyli funkcji wyszukaj.pionowo. A Justyna, która zadała pytanie ma przykładową tabelę:

Code Perso

CAP 112.00

CEP 63.00

HA1500P 77.00

HA1000P 56.00

I chce uzyskać taki efekt, aby po wpisaniu np: 1, automatycznie jej się pojawiła wartość 112.

W Excelu to nie jest problem, ponieważ taki efekt łatwo można uzyskać dzięki funkcji WYSZUKAJ.PIONOWO. Ale zamiast wpisywać np: 1 wpisujemy konkretną wartość, którą chcemy wyszukać.

Funkcja WYSZUKAJ.PIONOWO zwróci Ci wartość powiązaną z wyszukiwaną wartością z wybranej kolumny. Przykładowy zapis może wyglądać tak:

=WYSZUKAJ.PIONOWO(CAP;$A$2:$B$5;2;PRAWDA)

Pierwszą zmienną funkcją jest wyszukiwana wartość. Czyli przykładowo chcesz wyszukać CAP.

Następnie wpisujesz tabelę/tablicę/obszar, w którym chcesz znaleźć konkretną wartość.

Trzecia zmienna to numer kolumny, z której ma być pobrany wynik. Szczególnie przydatny, gdy masz tabelę składającą się z wielu kolumn. Czyli w naszym przykładzie kolumna z nagłówkiem Code ma numer 1, a z nagłówkiem Perso ma numer 2. Justyna chce, żeby była zwrócona wartość z 2 kolumny, czyli w funkcji wpisujemy 2.

Ostatnia zmienna oznacza sposób wyszukiwania. Czy ma być przybliżone, czy zmienne. PRAWDA - oznacza przybliżone wyszukiwanie, a FAŁSZ dokładne.

Trzeba uważać z wyszukiwaniem przybliżonym, bo gdy znajdzie bardzo podobną wartość to skończy swoje wyszukiwanie i zwróci wartość z wcześniejszego o 1 wiersza. Dlatego ważne jest, żebyś sortował swoje dane od A do Z.

Przy wyszukiwaniu dokładnym nie musisz się o to martwić.

Do poradnika Jak korzystać z funkcji wyszukiwania w pionie w Excelu przypisano następujące tagi:

excel wyszukaj pionowo poradniki excel funkcja wyszukiwania w pionie zadania excel excel w praktyce

Skomentuj poradnik

Poradnik Jak korzystać z funkcji wyszukiwania w pionie w Excelu skomentowało 0 osób.

Awatar użytkownika
Pozostało 1500 znaków

Komentarze

Ładuję komentarze...